aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2010-04-17 12:10:53 -0400
committerGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2010-04-17 12:10:53 -0400
commitce32f90fdd4ebb5581b6ac28504e3d2b6d2df9dd (patch)
tree272b9cb4d7fdfa26976ba932effbb6c8600ed21f /CMakeLists.txt
parentba5b5f6a4b9b446c62eea43a2bd92e43a9dae8fe (diff)
clarify help message about make install
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7c68b0f71..f5f10ab81 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -224,10 +224,12 @@ if(cmake_generator_tolower MATCHES "makefile")
message("--------------+----------------------------------------------------------------")
message("Command | Description")
message("--------------+----------------------------------------------------------------")
- message("make install | Install to ${CMAKE_INSTALL_PREFIX}")
- message(" | To change that: cmake . -DCMAKE_INSTALL_PREFIX=yourpath")
- message(" | Header files are installed to ${INCLUDE_INSTALL_DIR}")
- message(" | To change that: cmake . -DEIGEN_INCLUDE_INSTALL_DIR=yourpath")
+ message("make install | Install to ${CMAKE_INSTALL_PREFIX}. To change that:")
+ message(" | cmake . -DCMAKE_INSTALL_PREFIX=yourpath")
+ message(" | Eigen headers will then be installed to:")
+ message(" | ${INCLUDE_INSTALL_DIR}")
+ message(" | To install Eigen headers to a separate location, do:")
+ message(" | cmake . -DEIGEN_INCLUDE_INSTALL_DIR=yourpath")
message("make doc | Generate the API documentation, requires Doxygen & LaTeX")
message("make check | Build and run the unit-tests. Read this page:")
message(" | http://eigen.tuxfamily.org/index.php?title=Tests")