aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benoit Steiner <benoit.steiner.goog@gmail.com>2016-11-03 04:00:49 -0700
committerGravatar Benoit Steiner <benoit.steiner.goog@gmail.com>2016-11-03 04:00:49 -0700
commitca0ba0d9a41683832ce0cd5e208b2696aab61e11 (patch)
tree7b2bc2137c7f843a40c166246de2d8f611e7e838 /CMakeLists.txt
parentc80587c92b019de2bd31572aea95e5e6144f4207 (diff)
Improved AVX512 support
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4f5cc7376..2a5ca42bf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -133,7 +133,6 @@ if(NOT MSVC)
if(COMPILER_SUPPORT_WERROR)
set(CMAKE_REQUIRED_FLAGS "-Werror")
endif()
- ei_add_cxx_compiler_flag("-static")
ei_add_cxx_compiler_flag("-pedantic")
ei_add_cxx_compiler_flag("-Wall")
ei_add_cxx_compiler_flag("-Wextra")
@@ -233,7 +232,7 @@ if(NOT MSVC)
option(EIGEN_TEST_AVX512 "Enable/Disable AVX512 in tests/examples" OFF)
if(EIGEN_TEST_AVX512)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mavx512f -fabi-version=6")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mavx512f -fabi-version=6" -DEIGEN_ENABLE_AVX512)
message(STATUS "Enabling AVX512 in tests/examples")
endif()