aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Hauke Heibel <hauke.heibel@gmail.com>2011-10-04 11:23:55 +0200
committerGravatar Hauke Heibel <hauke.heibel@gmail.com>2011-10-04 11:23:55 +0200
commitb96d0bd240c0b81947244e47a6568680d41ae348 (patch)
treec520f367e3dcbf05035e236ef14bfea4a08c4dd9 /CMakeLists.txt
parent683ea3c93fc2bf1c4724252c0eef70aa4b8ca2b0 (diff)
Added a flag to build blas/lapack.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt22
1 files changed, 17 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ab44f22c1..44ff6d188 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -343,12 +343,24 @@ else()
add_subdirectory(test EXCLUDE_FROM_ALL)
endif()
-if(EIGEN_LEAVE_TEST_IN_ALL_TARGET)
- add_subdirectory(blas)
- add_subdirectory(lapack)
+ # The flag below can be removed when the CMake issue
+ # http://public.kitware.com/Bug/view.php?id=9220
+ # is fixed and when the cmake_minimum_required(VERSION ...)
+ # is accordingly adapted.
+if(MSVC)
+ set(EIGEN_BUILD_BLAS_LAPACK FALSE CACHE BOOL "Activates blas and lapack subfolders inclusion.")
else()
- add_subdirectory(blas EXCLUDE_FROM_ALL)
- add_subdirectory(lapack EXCLUDE_FROM_ALL)
+ set(EIGEN_BUILD_BLAS_LAPACK TRUE CACHE BOOL "Activates blas and lapack subfolders inclusion.")
+endif()
+
+if(EIGEN_BUILD_BLAS_LAPACK)
+ if(EIGEN_LEAVE_TEST_IN_ALL_TARGET)
+ add_subdirectory(blas)
+ add_subdirectory(lapack)
+ else()
+ add_subdirectory(blas EXCLUDE_FROM_ALL)
+ add_subdirectory(lapack EXCLUDE_FROM_ALL)
+ endif()
endif()
add_subdirectory(unsupported)