aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benoit Steiner <benoit.steiner.goog@gmail.com>2016-02-25 09:06:18 -0800
committerGravatar Benoit Steiner <benoit.steiner.goog@gmail.com>2016-02-25 09:06:18 -0800
commitaf199b4658963cc9cb7b91ba09b3f6f8f3c8017c (patch)
tree1ec5423b4e39ebeb7f2d657481c32f991b966ca6 /CMakeLists.txt
parentc36c09169e1545e287293f3f145fa5a25b47b84a (diff)
Made the CUDA architecture level a build setting.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index eaee5d5e2..1c979747c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -336,6 +336,8 @@ endif()
option(EIGEN_TEST_CXX11 "Enable testing with C++11 and C++11 features (e.g. Tensor module)." OFF)
+set(EIGEN_CUDA_COMPUTE_ARCH 30 CACHE STRING "The CUDA compute architecture level to target when compiling CUDA code")
+
include_directories(${CMAKE_CURRENT_SOURCE_DIR} ${CMAKE_CURRENT_BINARY_DIR})
# Backward compatibility support for EIGEN_INCLUDE_INSTALL_DIR