aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Konstantinos Margaritis <markos@freevec.org>2016-03-21 13:46:47 -0400
committerGravatar Konstantinos Margaritis <markos@freevec.org>2016-03-21 13:46:47 -0400
commita9a6710e151ccd5d4fa9a6178db4413ed0c74911 (patch)
tree3c09ecd1f8ce9c8871609caa1ff07373c128925e /CMakeLists.txt
parentb224771f403def7ade226a7410262361f495f668 (diff)
add initial s390x(zEC13) ZVECTOR support
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 95f4c8d7c..51beba118 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -250,7 +250,11 @@ if(NOT MSVC)
message(STATUS "Enabling NEON in tests/examples")
endif()
-
+ option(EIGEN_TEST_ZVECTOR "Enable/Disable S390X(zEC13) ZVECTOR in tests/examples" OFF)
+ if(EIGEN_TEST_ZVECTOR)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -march=z13 -mzvector")
+ message(STATUS "Enabling S390X(zEC13) ZVECTOR in tests/examples")
+ endif()
check_cxx_compiler_flag("-fopenmp" COMPILER_SUPPORT_OPENMP)
if(COMPILER_SUPPORT_OPENMP)