aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Ram-Z <132314-Ram-Z@users.noreply.gitlab.com>2020-01-10 19:12:48 +0000
committerGravatar Christoph Hertzberg <chtz@informatik.uni-bremen.de>2020-02-28 20:46:53 +0000
commita45d28256d020a4e871267c9bf00206fe9d2265e (patch)
tree8c1becc77c803e8b5c8e4f6b06d1b5a0be03bcb1 /CMakeLists.txt
parent98bfc5aaa8cd411d23e173bcda7dbed794942399 (diff)
Don't restrict CMAKE_BUILD_TYPE
This prevents projects that add Eigen using `add_subdirectory` from using their own custom CMAKE_BUILD_TYPE and have Eigen respect the same custom flags.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 81c98a026..e4ca76c76 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,13 +20,6 @@ if (NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE "Release")
endif()
-string(TOLOWER "${CMAKE_BUILD_TYPE}" cmake_build_type_tolower)
-if( NOT cmake_build_type_tolower STREQUAL "debug"
- AND NOT cmake_build_type_tolower STREQUAL "release"
- AND NOT cmake_build_type_tolower STREQUAL "relwithdebinfo")
- message(FATAL_ERROR "Unknown build type \"${CMAKE_BUILD_TYPE}\". Allowed values are Debug, Release, RelWithDebInfo (case-insensitive).")
-endif()
-
#############################################################################
# retrieve version information #