aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2009-10-03 16:50:50 -0400
committerGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2009-10-03 16:50:50 -0400
commita1d9b76dd54679bf0e2f6ac2faca27b7417c6bdd (patch)
tree447442b12331396f512d59f0e5e898e1156705ec /CMakeLists.txt
parent3e4cb080549c39d8af80ce4e9b086a93a55a8f6a (diff)
add debug targets like debug_qr to build a specific test with debug info
remove the btest target, instead just do "make" since anyway we have to let "make" build the tests
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3f69c36cf..af49654d6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -146,10 +146,13 @@ message("Command | Description")
message("-------------+-----------------------------------------------------------------")
message("make install | Install to ${CMAKE_INSTALL_PREFIX}")
message(" | To change that, do: cmake . -DCMAKE_INSTALL_PREFIX=yourpath")
-message("make doc | Generate the API documentation, requires Doxygen & LaTeX")
-message("make btest | Build the unit tests (doesn't run them)")
+message("make | Build the unit tests")
+message(" | Note: that's NOT needed if you just want to install Eigen!")
message(" | Note: this takes lots of time & memory! Easy on the -j option!")
message("make test | Build and run the unit tests (using CTest)")
message("make test_qr | Build a specific test, here test_qr. To run it: test/test_qr")
+message("make debug_qr| Build a test with full debug info. To run it: test/debug_qr")
message("make blas | Build BLAS library")
+message("make doc | Generate the API documentation, requires Doxygen & LaTeX")
message("-------------+-----------------------------------------------------------------")
+