aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2013-03-20 08:40:13 +0100
committerGravatar Gael Guennebaud <g.gael@free.fr>2013-03-20 08:40:13 +0100
commit9bfeeba1c51e709740b222a7f62bdb1391de8f1a (patch)
tree37f419b2cdf4a2a6b4a4f71d8dd18609b4715e3f /CMakeLists.txt
parent11a9091084a68689a4434a546547c30ca94efbed (diff)
Add Official/Unsupported labels to unit tests and add a ctest driver to submit subprojects to cdash
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2003e15a2..6f45ff0b5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -311,6 +311,7 @@ add_subdirectory(Eigen)
add_subdirectory(doc EXCLUDE_FROM_ALL)
include(EigenConfigureTesting)
+
# fixme, not sure this line is still needed:
enable_testing() # must be called from the root CMakeLists, see man page
@@ -345,6 +346,8 @@ if(NOT WIN32)
add_subdirectory(bench/spbench EXCLUDE_FROM_ALL)
endif(NOT WIN32)
+configure_file(scripts/cdashtesting.cmake.in cdashtesting.cmake @ONLY)
+
ei_testing_print_summary()
message(STATUS "")