aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2009-11-15 21:12:15 -0500
committerGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2009-11-15 21:12:15 -0500
commit955cd7f88455a46c9c31a225a6a63a6a440e3415 (patch)
treebc140098de14421fa961d86d0246a96a8e802e3c /CMakeLists.txt
parent1aaa9059c01c105a97405ddf38e671fb89656c8b (diff)
* add PermutationMatrix
* DiagonalMatrix: - add MaxSizeAtCompileTime parameter - DiagonalOnTheLeft ---> OnTheLeft - fix bug in DiagonalMatrix::setIdentity()
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 7 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ee93e3de3..3a23479d7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -158,6 +158,7 @@ ei_testing_print_summary()
message("")
message("Configured Eigen ${EIGEN_VERSION_NUMBER}")
+message("")
string(TOLOWER "${CMAKE_GENERATOR}" cmake_generator_tolower)
if(cmake_generator_tolower MATCHES "makefile")
@@ -166,14 +167,15 @@ if(cmake_generator_tolower MATCHES "makefile")
message("Command | Description")
message("--------------+----------------------------------------------------------------")
message("make install | Install to ${CMAKE_INSTALL_PREFIX}")
- message(" | * To change that: cmake . -DCMAKE_INSTALL_PREFIX=yourpath")
+ message(" | To change that: cmake . -DCMAKE_INSTALL_PREFIX=yourpath")
message("make doc | Generate the API documentation, requires Doxygen & LaTeX")
- message("make check | Build and run the unit-tests")
+ message("make check | Build and run the unit-tests. Read this page:")
+ message(" | http://eigen.tuxfamily.org/index.php?title=Tests")
message("make blas | Build BLAS library (not the same thing as Eigen)")
message("--------------+----------------------------------------------------------------")
+else()
+ message("To build/run the unit tests, read this page:")
+ message(" http://eigen.tuxfamily.org/index.php?title=Tests")
endif()
message("")
-message("To build/run the unit tests, read this page:")
-message(" http://eigen.tuxfamily.org/index.php?title=Tests")
-message("")