aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2008-05-03 12:21:23 +0000
committerGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2008-05-03 12:21:23 +0000
commit8c6007f80e773ca3661c5a323d8e28ce49a609b3 (patch)
treebd06b3b59b4eb8b3ed6292ea5d9acf27d822b067 /CMakeLists.txt
parent0545df21497a7e3dab190b42b7cde840c9439395 (diff)
* Patch by Konstantinos Margaritis: AltiVec vectorization.
* Fix several warnings, temporarily disable determinant test.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ccb234a64..95a8a2311 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,6 +16,10 @@ IF(CMAKE_COMPILER_IS_GNUCXX)
SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -msse2")
MESSAGE("Enabling SSE2 in tests/examples")
ENDIF(TEST_SSE2)
+ IF(TEST_ALTIVEC)
+ SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -maltivec -mabi=altivec")
+ MESSAGE("Enabling AltiVec in tests/examples")
+ ENDIF(TEST_ALTIVEC)
ENDIF(CMAKE_SYSTEM_NAME MATCHES Linux)
ENDIF(CMAKE_COMPILER_IS_GNUCXX)