aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benoit Steiner <benoit.steiner.goog@gmail.com>2016-04-11 18:40:16 -0700
committerGravatar Benoit Steiner <benoit.steiner.goog@gmail.com>2016-04-11 18:40:16 -0700
commit8bfe739cd226882b57cf7bf9bff8c202df088bfc (patch)
treee9a7ae90de0ae3e136da01d4fbe9d44e7264c62a /CMakeLists.txt
parentd6e596174d09446236b3f398d8ec39148c638ed9 (diff)
Updated the AVX512 PacketMath to properly leverage the AVX512DQ instructions
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 05686ea64..003d00c06 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -223,7 +223,7 @@ if(NOT MSVC)
option(EIGEN_TEST_AVX512 "Enable/Disable AVX512 in tests/examples" OFF)
if(EIGEN_TEST_AVX512)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mavx512f")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mavx512f -mavx512dq")
message(STATUS "Enabling AVX512 in tests/examples")
endif()