aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2009-02-05 09:37:53 +0000
committerGravatar Gael Guennebaud <g.gael@free.fr>2009-02-05 09:37:53 +0000
commit8a6f38c6382da715691c1d8578f131e799049a93 (patch)
tree8b44b59ba5d216b7c2d9f155e2ef96e3546f1270 /CMakeLists.txt
parentda45184635855d280ff612ecaa79e5f7d40ffacd (diff)
forgot to commit changes in main CMakeLists.txt
(add unsupported folder)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a88a5eb6a..bce4508c3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -84,6 +84,12 @@ endif(EIGEN_TEST_NO_EXPLICIT_VECTORIZATION)
include_directories(${CMAKE_CURRENT_SOURCE_DIR} ${CMAKE_CURRENT_BINARY_DIR})
+set(INCLUDE_INSTALL_DIR
+ "${CMAKE_INSTALL_PREFIX}/include/eigen2"
+ CACHE PATH
+ "The directory where we install the header files"
+ FORCE)
+
add_subdirectory(Eigen)
if(EIGEN_BUILD_TESTS)
@@ -93,6 +99,8 @@ endif(EIGEN_BUILD_TESTS)
add_subdirectory(doc)
+add_subdirectory(unsupported)
+
if(EIGEN_BUILD_DEMOS)
add_subdirectory(demos)
endif(EIGEN_BUILD_DEMOS)