aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2009-10-19 15:56:03 -0400
committerGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2009-10-19 15:56:03 -0400
commit890bff977eeff9a5d461812a0048c89ea30fd30a (patch)
tree73a1e45d68e75e769a996aee287c99ec8ec49067 /CMakeLists.txt
parent6c1b91678b5406fb10fe5d4692014f8017d1cf1c (diff)
* proper check for Make
* fix documentation of ei_add_test
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt34
1 files changed, 18 insertions, 16 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0c068e6f5..ed9e6d183 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -142,21 +142,23 @@ if(EIGEN_BUILD_BTL)
endif(EIGEN_BUILD_BTL)
ei_testing_print_summary()
-if(NOT MSVC_IDE)
+
message("")
message("Configured Eigen ${EIGEN_VERSION_NUMBER}")
-message("You can now do the following:")
-message("--------------+----------------------------------------------------------------")
-message("Command | Description")
-message("--------------+----------------------------------------------------------------")
-message("make install | Install to ${CMAKE_INSTALL_PREFIX}")
-message(" | * To change that: cmake . -DCMAKE_INSTALL_PREFIX=yourpath")
-message("make btest | Build the unit tests")
-message(" | * That takes lots of memory! Easy on the -j option")
-message("make test | Build and run the unit tests (using CTest)")
-message("make test_qr | Build a specific test, here test_qr. To run it: test/test_qr")
-message("make debug_qr | Build a test with full debug info. To run it: test/debug_qr")
-message("make blas | Build BLAS library (not the same thing as Eigen)")
-message("make doc | Generate the API documentation, requires Doxygen & LaTeX")
-message("--------------+----------------------------------------------------------------")
-endif(NOT MSVC_IDE)
+
+string(TOLOWER "${CMAKE_GENERATOR}" cmake_generator_tolower)
+if(cmake_generator_tolower MATCHES "makefile")
+ message("You can now do the following:")
+ message("--------------+----------------------------------------------------------------")
+ message("Command | Description")
+ message("--------------+----------------------------------------------------------------")
+ message("make install | Install to ${CMAKE_INSTALL_PREFIX}")
+ message(" | * To change that: cmake . -DCMAKE_INSTALL_PREFIX=yourpath")
+ message("make btest | Build the unit tests")
+ message("make test | Build and run the unit tests (using CTest)")
+ message("make test_qr | Build a specific test, here test_qr. To run it: test/test_qr")
+ message("make debug_qr | Build a test with full debug info. To run it: test/debug_qr")
+ message("make blas | Build BLAS library (not the same thing as Eigen)")
+ message("make doc | Generate the API documentation, requires Doxygen & LaTeX")
+ message("--------------+----------------------------------------------------------------")
+endif()