aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Jose Luis Blanco <joseluisblancoc@gmail.com>2010-12-29 22:02:01 +0100
committerGravatar Jose Luis Blanco <joseluisblancoc@gmail.com>2010-12-29 22:02:01 +0100
commit7feb644620578c2487a68827a68f941fa29ad592 (patch)
tree69b1a11cd9cb0dd28e3a19105c1bf647f95a13ef /CMakeLists.txt
parent902af035d36530c3cb174aa98a48dc13810ff42d (diff)
Switched "MESSAGE(" -> "MESSAGE(STATUS " in CMake script, since otherwise they may look like errors to the user.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt70
1 files changed, 35 insertions, 35 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9686fd162..ad8ec5771 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -118,43 +118,43 @@ if(CMAKE_COMPILER_IS_GNUCXX)
option(EIGEN_TEST_SSE2 "Enable/Disable SSE2 in tests/examples" OFF)
if(EIGEN_TEST_SSE2)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -msse2")
- message("Enabling SSE2 in tests/examples")
+ message(STATUS "Enabling SSE2 in tests/examples")
endif()
option(EIGEN_TEST_SSE3 "Enable/Disable SSE3 in tests/examples" OFF)
if(EIGEN_TEST_SSE3)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -msse3")
- message("Enabling SSE3 in tests/examples")
+ message(STATUS "Enabling SSE3 in tests/examples")
endif()
option(EIGEN_TEST_SSSE3 "Enable/Disable SSSE3 in tests/examples" OFF)
if(EIGEN_TEST_SSSE3)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mssse3")
- message("Enabling SSSE3 in tests/examples")
+ message(STATUS "Enabling SSSE3 in tests/examples")
endif()
option(EIGEN_TEST_SSE4_1 "Enable/Disable SSE4.1 in tests/examples" OFF)
if(EIGEN_TEST_SSE4_1)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -msse4.1")
- message("Enabling SSE4.1 in tests/examples")
+ message(STATUS "Enabling SSE4.1 in tests/examples")
endif()
option(EIGEN_TEST_SSE4_2 "Enable/Disable SSE4.2 in tests/examples" OFF)
if(EIGEN_TEST_SSE4_2)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -msse4.2")
- message("Enabling SSE4.2 in tests/examples")
+ message(STATUS "Enabling SSE4.2 in tests/examples")
endif()
option(EIGEN_TEST_ALTIVEC "Enable/Disable AltiVec in tests/examples" OFF)
if(EIGEN_TEST_ALTIVEC)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -maltivec -mabi=altivec")
- message("Enabling AltiVec in tests/examples")
+ message(STATUS "Enabling AltiVec in tests/examples")
endif()
option(EIGEN_TEST_NEON "Enable/Disable Neon in tests/examples" OFF)
if(EIGEN_TEST_NEON)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mfloat-abi=softfp -mfpu=neon -mcpu=cortex-a8")
- message("Enabling NEON in tests/examples")
+ message(STATUS "Enabling NEON in tests/examples")
endif()
check_cxx_compiler_flag("-fopenmp" COMPILER_SUPPORT_OPENMP)
@@ -162,7 +162,7 @@ if(CMAKE_COMPILER_IS_GNUCXX)
option(EIGEN_TEST_OPENMP "Enable/Disable OpenMP in tests/examples" OFF)
if(EIGEN_TEST_OPENMP)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fopenmp")
- message("Enabling OpenMP in tests/examples")
+ message(STATUS "Enabling OpenMP in tests/examples")
endif()
endif()
@@ -186,7 +186,7 @@ if(MSVC)
option(EIGEN_TEST_OPENMP "Enable/Disable OpenMP in tests/examples" OFF)
if(EIGEN_TEST_OPENMP)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /openmp")
- message("Enabling OpenMP in tests/examples")
+ message(STATUS "Enabling OpenMP in tests/examples")
endif()
endif()
@@ -196,7 +196,7 @@ if(MSVC)
# arch is not supported on 64 bit systems, SSE is enabled automatically.
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /arch:SSE2")
endif(NOT CMAKE_CL_64)
- message("Enabling SSE2 in tests/examples")
+ message(STATUS "Enabling SSE2 in tests/examples")
endif(EIGEN_TEST_SSE2)
endif(MSVC)
@@ -207,21 +207,21 @@ if(EIGEN_TEST_X87)
set(EIGEN_TEST_NO_EXPLICIT_VECTORIZATION ON)
if(CMAKE_COMPILER_IS_GNUCXX)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mfpmath=387")
- message("Forcing use of x87 instructions in tests/examples")
+ message(STATUS "Forcing use of x87 instructions in tests/examples")
else()
- message("EIGEN_TEST_X87 ignored on your compiler")
+ message(STATUS "EIGEN_TEST_X87 ignored on your compiler")
endif()
endif()
if(EIGEN_TEST_NO_EXPLICIT_VECTORIZATION)
add_definitions(-DEIGEN_DONT_VECTORIZE=1)
- message("Disabling vectorization in tests/examples")
+ message(STATUS "Disabling vectorization in tests/examples")
endif()
option(EIGEN_TEST_NO_EXPLICIT_ALIGNMENT "Disable explicit alignment (hence vectorization) in tests/examples" OFF)
if(EIGEN_TEST_NO_EXPLICIT_ALIGNMENT)
add_definitions(-DEIGEN_DONT_ALIGN=1)
- message("Disabling alignment in tests/examples")
+ message(STATUS "Disabling alignment in tests/examples")
endif()
option(EIGEN_TEST_C++0x "Enables all C++0x features." OFF)
@@ -307,30 +307,30 @@ endif(EIGEN_BUILD_BTL)
ei_testing_print_summary()
-message("")
-message("Configured Eigen ${EIGEN_VERSION_NUMBER}")
-message("")
+message(STATUS "")
+message(STATUS "Configured Eigen ${EIGEN_VERSION_NUMBER}")
+message(STATUS "")
string(TOLOWER "${CMAKE_GENERATOR}" cmake_generator_tolower)
if(cmake_generator_tolower MATCHES "makefile")
- message("Some things you can do now:")
- message("--------------+----------------------------------------------------------------")
- message("Command | Description")
- message("--------------+----------------------------------------------------------------")
- message("make install | Install to ${CMAKE_INSTALL_PREFIX}. To change that:")
- message(" | cmake . -DCMAKE_INSTALL_PREFIX=yourpath")
- message(" | Eigen headers will then be installed to:")
- message(" | ${INCLUDE_INSTALL_DIR}")
- message(" | To install Eigen headers to a separate location, do:")
- message(" | cmake . -DEIGEN_INCLUDE_INSTALL_DIR=yourpath")
- message("make doc | Generate the API documentation, requires Doxygen & LaTeX")
- message("make check | Build and run the unit-tests. Read this page:")
- message(" | http://eigen.tuxfamily.org/index.php?title=Tests")
- message("make blas | Build BLAS library (not the same thing as Eigen)")
- message("--------------+----------------------------------------------------------------")
+ message(STATUS "Some things you can do now:")
+ message(STATUS "--------------+----------------------------------------------------------------")
+ message(STATUS "Command | Description")
+ message(STATUS "--------------+----------------------------------------------------------------")
+ message(STATUS "make install | Install to ${CMAKE_INSTALL_PREFIX}. To change that:")
+ message(STATUS " | cmake . -DCMAKE_INSTALL_PREFIX=yourpath")
+ message(STATUS " | Eigen headers will then be installed to:")
+ message(STATUS " | ${INCLUDE_INSTALL_DIR}")
+ message(STATUS " | To install Eigen headers to a separate location, do:")
+ message(STATUS " | cmake . -DEIGEN_INCLUDE_INSTALL_DIR=yourpath")
+ message(STATUS "make doc | Generate the API documentation, requires Doxygen & LaTeX")
+ message(STATUS "make check | Build and run the unit-tests. Read this page:")
+ message(STATUS " | http://eigen.tuxfamily.org/index.php?title=Tests")
+ message(STATUS "make blas | Build BLAS library (not the same thing as Eigen)")
+ message(STATUS "--------------+----------------------------------------------------------------")
else()
- message("To build/run the unit tests, read this page:")
- message(" http://eigen.tuxfamily.org/index.php?title=Tests")
+ message(STATUS "To build/run the unit tests, read this page:")
+ message(STATUS " http://eigen.tuxfamily.org/index.php?title=Tests")
endif()
-message("")
+message(STATUS "")