aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2014-03-27 15:38:40 +0100
committerGravatar Gael Guennebaud <g.gael@free.fr>2014-03-27 15:38:40 +0100
commit7d73c7f18be20407ffd28f72b3275da233658f80 (patch)
treef2431e91ba1f19ebbfff34c6ad55da2c44207641 /CMakeLists.txt
parent6f123d209e65a8cf324df53a9a7e87d8e4c47e9f (diff)
Change abi version when enabling AVX with GCC
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fb13769f4..838a41b79 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -199,6 +199,9 @@ if(NOT MSVC)
option(EIGEN_TEST_AVX "Enable/Disable AVX in tests/examples" OFF)
if(EIGEN_TEST_AVX)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mavx")
+ if(CMAKE_COMPILER_IS_GNUCXX)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fabi-version=6")
+ endif()
message(STATUS "Enabling AVX in tests/examples")
endif()