aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2013-06-21 09:24:57 +0200
committerGravatar Gael Guennebaud <g.gael@free.fr>2013-06-21 09:24:57 +0200
commit7adfca5af2bce896af375158b82d23f26f76d3f4 (patch)
tree41cb936ca6e4bd452e902a2c17aa5d8f5320f94c /CMakeLists.txt
parentc0cad44da68634a8afbaa6d7f1020d87cec95d64 (diff)
Shutdown clang warning: argument unused during compilation: '-ansi' at linking time
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5da47deb8..ad0269ea6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -156,6 +156,8 @@ if(NOT MSVC)
# The -ansi flag must be added last, otherwise it is also used as a linker flag by check_cxx_compiler_flag making it fails
# Moreover we should not set both -strict-ansi and -ansi
check_cxx_compiler_flag("-strict-ansi" COMPILER_SUPPORT_STRICTANSI)
+ ei_add_cxx_compiler_flag("-Qunused-arguments") # disable clang warning: argument unused during compilation: '-ansi'
+
if(COMPILER_SUPPORT_STRICTANSI)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -strict-ansi")
else()