aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2010-04-08 13:28:21 +0200
committerGravatar Gael Guennebaud <g.gael@free.fr>2010-04-08 13:28:21 +0200
commit7a59f9ae01ba3643caf12dab6aab397602cf99e5 (patch)
tree39a89087c57158ec18989c58d551e5bd9f77eca4 /CMakeLists.txt
parent4e871c6c8082ed7f11aadfb53eef4ecc7e60c948 (diff)
make sure that changing CMAKE_INSTALL_PREFIX is properly taken into account
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt23
1 files changed, 19 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a85bbf222..7c68b0f71 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -152,11 +152,24 @@ option(EIGEN_TEST_C++0x "Enables all C++0x features." OFF)
include_directories(${CMAKE_CURRENT_SOURCE_DIR} ${CMAKE_CURRENT_BINARY_DIR})
-set(INCLUDE_INSTALL_DIR
+# the user modifiable install path for header files
+set(EIGEN_INCLUDE_INSTALL_DIR ${EIGEN_INCLUDE_INSTALL_DIR} CACHE PATH "The directory where we install the header files (optional)")
+
+# set the internal install path for header files which depends on wether the user modifiable
+# EIGEN_INCLUDE_INSTALL_DIR has been set by the user or not.
+if(EIGEN_INCLUDE_INSTALL_DIR)
+ set(INCLUDE_INSTALL_DIR
+ ${EIGEN_INCLUDE_INSTALL_DIR}
+ CACHE INTERNAL
+ "The directory where we install the header files (internal)"
+ )
+else()
+ set(INCLUDE_INSTALL_DIR
"${CMAKE_INSTALL_PREFIX}/include/eigen3"
- CACHE PATH
- "The directory where we install the header files"
-)
+ CACHE INTERNAL
+ "The directory where we install the header files (internal)"
+ )
+endif()
install(FILES
signature_of_eigen3_matrix_library
@@ -213,6 +226,8 @@ if(cmake_generator_tolower MATCHES "makefile")
message("--------------+----------------------------------------------------------------")
message("make install | Install to ${CMAKE_INSTALL_PREFIX}")
message(" | To change that: cmake . -DCMAKE_INSTALL_PREFIX=yourpath")
+ message(" | Header files are installed to ${INCLUDE_INSTALL_DIR}")
+ message(" | To change that: cmake . -DEIGEN_INCLUDE_INSTALL_DIR=yourpath")
message("make doc | Generate the API documentation, requires Doxygen & LaTeX")
message("make check | Build and run the unit-tests. Read this page:")
message(" | http://eigen.tuxfamily.org/index.php?title=Tests")