aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2018-12-12 15:48:36 +0100
committerGravatar Gael Guennebaud <g.gael@free.fr>2018-12-12 15:48:36 +0100
commit72c0bbe2bd1c49c75b6efdb81d0558f8b62578d1 (patch)
tree0085849ac123593d69b5d53e6c11abcbee8f024b /CMakeLists.txt
parent37c91e18368e77a333afd2f5a1fd52026014fca5 (diff)
Simplify handling of tests that must fail to compile.
Each test is now a normal ctest target, and build properties (compiler+flags) are preserved (instead of starting a new build-dir from scratch).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e18428e50..5255e9600 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -519,10 +519,7 @@ message(STATUS "")
message(STATUS "Configured Eigen ${EIGEN_VERSION_NUMBER}")
message(STATUS "")
-option(EIGEN_FAILTEST "Enable failtests." OFF)
-if(EIGEN_FAILTEST)
- add_subdirectory(failtest)
-endif()
+add_subdirectory(failtest)
string(TOLOWER "${CMAKE_GENERATOR}" cmake_generator_tolower)
if(cmake_generator_tolower MATCHES "makefile")