aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2009-05-20 00:05:28 +0200
committerGravatar Gael Guennebaud <g.gael@free.fr>2009-05-20 00:05:28 +0200
commit6ecd02d7ec85f07e02559cb311d4dd07e844a72d (patch)
tree3703e87d24166af9d2e74a8522c92c3393b6557b /CMakeLists.txt
parent56aad5aafb84b87c9cdf8a237a3d7fdf632b2021 (diff)
parenta697cb409440c3d01eda44f84abe2f1d924270ce (diff)
merge
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1d84e9107..dc26e71d1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -37,6 +37,9 @@ if(NOT WIN32)
option(EIGEN_BUILD_LIB "Build the binary shared library" OFF)
endif(NOT WIN32)
option(EIGEN_BUILD_BTL "Build benchmark suite" OFF)
+if(NOT WIN32)
+ option(EIGEN_BUILD_PKGCONFIG "Build pkg-config .pc file for Eigen" ON)
+endif(NOT WIN32)
if(EIGEN_BUILD_LIB)
option(EIGEN_TEST_LIB "Build the unit tests using the library (disable -pedantic)" OFF)
@@ -108,6 +111,13 @@ set(INCLUDE_INSTALL_DIR
"The directory where we install the header files"
FORCE)
+if(EIGEN_BUILD_PKGCONFIG)
+ configure_file(eigen2.pc.in eigen2.pc)
+ install(FILES eigen2.pc
+ DESTINATION lib/pkgconfig
+ )
+endif(EIGEN_BUILD_PKGCONFIG)
+
add_subdirectory(Eigen)
add_subdirectory(doc)
@@ -129,4 +139,4 @@ endif(EIGEN_BUILD_BTL)
if(EIGEN_BUILD_TESTS)
ei_testing_print_summary()
-endif(EIGEN_BUILD_TESTS) \ No newline at end of file
+endif(EIGEN_BUILD_TESTS)