aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benoit Steiner <benoit.steiner.goog@gmail.com>2014-01-29 11:43:05 -0800
committerGravatar Benoit Steiner <benoit.steiner.goog@gmail.com>2014-01-29 11:43:05 -0800
commit64a85800bd3573a7da7a396fde9707dce87a58d9 (patch)
tree6f82e2c24497038548e594f00b8b29f9affe66b9 /CMakeLists.txt
parenta7621809fe0fc7c65446ab9a83739ebe313004d4 (diff)
Added support for AVX to Eigen.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a4731c8c1..16a9b5bcb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -196,6 +196,12 @@ if(NOT MSVC)
message(STATUS "Enabling SSE4.2 in tests/examples")
endif()
+ option(EIGEN_TEST_AVX "Enable/Disable AVX in tests/examples" ON)
+ if(EIGEN_TEST_AVX)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mavx")
+ message(STATUS "Enabling AVX in tests/examples")
+ endif()
+
option(EIGEN_TEST_ALTIVEC "Enable/Disable AltiVec in tests/examples" OFF)
if(EIGEN_TEST_ALTIVEC)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -maltivec -mabi=altivec")