aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2008-05-31 23:21:49 +0000
committerGravatar Gael Guennebaud <g.gael@free.fr>2008-05-31 23:21:49 +0000
commit64169389edb9f852bd7fabe15b4cc1ba909a9796 (patch)
tree0b9d70fa6a169e556bb84ff7d5645ea39fe90f94 /CMakeLists.txt
parentfcf4457b781831b51ac70d4141b29b062d29fdf3 (diff)
added an *optional* Eigen2 dynamic library.
it allows the possiblity to save some compilation time by linking to it *and* defining the token EIGEN_EXTERN_INSTANCIATIONS
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 95a8a2311..a4aaee03b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,7 @@
PROJECT(Eigen)
+CMAKE_MINIMUM_REQUIRED(VERSION 2.4)
+
OPTION(BUILD_TESTS "Build tests" OFF)
OPTION(BUILD_DOC "Build documentation and examples" OFF)