aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2014-04-22 16:03:19 +0200
committerGravatar Gael Guennebaud <g.gael@free.fr>2014-04-22 16:03:19 +0200
commit5c5231ab71ba51432a24fdfd7d36a835b44805ea (patch)
tree395149bfb0225a33f9db09b9c9766b8641acb404 /CMakeLists.txt
parent2606abed535744fcaa41b923c71338a06b8ed3fa (diff)
Workaround gcc's default ABI not being able to distinghish between vector types of different sizes.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 838a41b79..fb13769f4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -199,9 +199,6 @@ if(NOT MSVC)
option(EIGEN_TEST_AVX "Enable/Disable AVX in tests/examples" OFF)
if(EIGEN_TEST_AVX)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mavx")
- if(CMAKE_COMPILER_IS_GNUCXX)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fabi-version=6")
- endif()
message(STATUS "Enabling AVX in tests/examples")
endif()