aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Hans Johnson <hans-johnson@uiowa.edu>2020-08-28 07:41:31 -0500
committerGravatar Hans Johnson <hans-johnson@uiowa.edu>2020-08-28 22:57:16 +0000
commit5b9bfc892a39ad2e95ad7dc9131e777d8f38f587 (patch)
treea6f9d7ac78545e38772fa9ce73343852c5a1e203 /CMakeLists.txt
parente5886457c8bea93018415e441242a4c50a2da7db (diff)
BUG: cmake_minimum_required must be the first command
https://cmake.org/cmake/help/v3.5/command/project.html Note: Call the cmake_minimum_required() command at the beginning of the top-level CMakeLists.txt file even before calling the project() command. It is important to establish version and policy settings before invoking other commands whose behavior they may affect. See also policy CMP0000.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ef78e3fc3..f083dc3c7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,7 +1,8 @@
-project(Eigen3)
-
+# cmake_minimum_require must be the first command of the file
cmake_minimum_required(VERSION 3.5.0)
+project(Eigen3)
+
# guard against in-source builds
if(${CMAKE_SOURCE_DIR} STREQUAL ${CMAKE_BINARY_DIR})
@@ -667,4 +668,4 @@ add_custom_target ( uninstall
if (EIGEN_SPLIT_TESTSUITE)
ei_split_testsuite("${EIGEN_SPLIT_TESTSUITE}")
-endif() \ No newline at end of file
+endif()