aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Hauke Heibel <hauke.heibel@gmail.com>2010-10-25 18:49:39 +0200
committerGravatar Hauke Heibel <hauke.heibel@gmail.com>2010-10-25 18:49:39 +0200
commit597b2745e1cfe1bf1cc4c4c189ecd16d2a0c1738 (patch)
treeec124140a98677a00b928e256f2bfc7bbcad483c /CMakeLists.txt
parent724af1354076194d23a85a4fdbd7634c5c4e19cb (diff)
Allow unset ${CMAKE_BUILD_TYPE} which is required for some targets and corresponding to using default values.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 111b8bf04..15dbbc4fa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,8 +13,9 @@ endif()
string(TOLOWER "${CMAKE_BUILD_TYPE}" cmake_build_type_tolower)
if( NOT cmake_build_type_tolower STREQUAL "debug"
AND NOT cmake_build_type_tolower STREQUAL "release"
- AND NOT cmake_build_type_tolower STREQUAL "relwithdebinfo")
- message(FATAL_ERROR "Unknown build type ${CMAKE_BUILD_TYPE}. Allowed values are Debug, Release, RelWithDebInfo (case-insensitive).")
+ AND NOT cmake_build_type_tolower STREQUAL "relwithdebinfo"
+ AND NOT cmake_build_type_tolower STREQUAL "")
+ message(FATAL_ERROR "Unknown build type \"${CMAKE_BUILD_TYPE}\". Allowed values are Debug, Release, RelWithDebInfo and \"\" (case-insensitive).")
endif()