aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Sheng Yang <yang.sheng@intel.com>2020-07-14 01:34:03 +0000
committerGravatar Rasmus Munk Larsen <rmlarsen@google.com>2020-07-14 01:34:03 +0000
commit56b3e3f3f8ca9972ca390c8296fde363bdab271c (patch)
tree5d06bf0995ed07dd232e346369e71f70561b5d9c /CMakeLists.txt
parent4ab32e2de2511746e2108563a43cbbeb1922fbf2 (diff)
AVX path for BF16
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 28103856e..867d068d2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -239,6 +239,12 @@ if(NOT MSVC)
message(STATUS "Enabling FMA in tests/examples")
endif()
+ option(EIGEN_TEST_AVX2 "Enable/Disable AVX2 in tests/examples" OFF)
+ if(EIGEN_TEST_AVX2)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mavx2 -mfma")
+ message(STATUS "Enabling AVX2 in tests/examples")
+ endif()
+
option(EIGEN_TEST_AVX512 "Enable/Disable AVX512 in tests/examples" OFF)
if(EIGEN_TEST_AVX512)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mavx512f -mfma")