aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2007-05-30 06:57:40 +0000
committerGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2007-05-30 06:57:40 +0000
commit47b935fc42cbf2ca992d8a270bc1b0fc97d1f6bc (patch)
tree81766357614fec6932ac833c262ce308cce2582f /CMakeLists.txt
parent3036eeca0abfee39d2a0feab4ae3ff1d28975999 (diff)
add initial CMakeLists
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 000000000..09558963f
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,17 @@
+project(eigen2)
+
+OPTION(BUILD_TESTS "Build tests" OFF)
+OPTION(BUILD_EXAMPLES "Build examples" OFF)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+if(CMAKE_COMPILER_IS_GNUCXX)
+ if (CMAKE_SYSTEM_NAME MATCHES Linux)
+ set ( CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-long-long -ansi -Wundef -Wcast-align -Werror-implicit-function-declaration -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security -Wmissing-format-attribute -fno-common")
+ set ( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wnon-virtual-dtor -Wno-long-long -ansi -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security -fno-exceptions -fno-check-new -fno-common")
+ endif (CMAKE_SYSTEM_NAME MATCHES Linux)
+endif (CMAKE_COMPILER_IS_GNUCXX)
+
+include_directories( ${CMAKE_SOURCE_DIR} ${CMAKE_BINARY_DIR} )
+
+add_subdirectory(tvmet-1.7.1)