aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2009-09-28 11:08:31 -0400
committerGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2009-09-28 11:08:31 -0400
commit457b7cba96517328b086d23b9ee47a50176c5982 (patch)
treea3613031b5c03d8b4e4055367e2d16b89f01303e /CMakeLists.txt
parenteeabd18afc5fca290612aada629a294f85d9d353 (diff)
more message improvements, tell the user about building a specific test
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1edc1eb12..c1c9ee546 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -145,10 +145,11 @@ message("-------------+---------------------------------------------------------
message("Command | Description")
message("-------------+-----------------------------------------------------------------")
message("make install | Install to ${CMAKE_INSTALL_PREFIX}")
-message(" | Do: cmake . -DCMAKE_INSTALL_PREFIX=yourprefix to change that")
-message("make test | Build and run the unit tests (using CTest)")
-message(" | Note: this takes lots of time & memory! Easy on the -j option!")
-message("make btest | Only build tests, don't run them")
+message(" | To change that, do: cmake . -DCMAKE_INSTALL_PREFIX=yourpath")
message("make doc | Generate the API documentation, requires Doxygen & LaTeX")
+message("make btest | Build the unit tests (doesn't run them)")
+message(" | Note: this takes lots of time & memory! Easy on the -j option!")
+message("make test | Build and run the unit tests (using CTest)")
+message("make test_qr | Build a specific test, here test_qr. To run it: test/test_qr")
message("make blas | Build BLAS library")
message("-------------+-----------------------------------------------------------------")