aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2013-04-17 10:23:08 +0200
committerGravatar Gael Guennebaud <g.gael@free.fr>2013-04-17 10:23:08 +0200
commit41b3c56e611dfcafa5550da6646c474c879521b0 (patch)
tree717d562e1df4ea0cbb3fbd2d5b39f9a4f77195fb /CMakeLists.txt
parent9a4caf2b0f501b8bb3628c2199504c8be841aa0c (diff)
Disable "operands are evaluated in unspecified order" ICC's remark
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 835eeb5ec..de25c69f9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -150,6 +150,7 @@ if(NOT MSVC)
ei_add_cxx_compiler_flag("-fno-check-new")
ei_add_cxx_compiler_flag("-fno-common")
ei_add_cxx_compiler_flag("-fstrict-aliasing")
+ ei_add_cxx_compiler_flag("-wd981") # disbale ICC's "operands are evaluated in unspecified order" remark
# The -ansi flag must be added last, otherwise it is also used as a linker flag by check_cxx_compiler_flag making it fails
# Moreover we should not set both -strict-ansi and -ansi