aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2009-02-27 16:19:13 +0000
committerGravatar Gael Guennebaud <g.gael@free.fr>2009-02-27 16:19:13 +0000
commit40774c625e7d47898bb171287c508c99b0b14fc0 (patch)
tree0fcd2296f5949f3b553da2187377435ce7c38d55 /CMakeLists.txt
parent170128770a2c934e9af8cda3642e3fbd44048668 (diff)
add a proof of concept autodiff jacobian helper class based on adolc
with unit test and FindAdolc cmake module
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 61f6a91a6..ff592f646 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -92,13 +92,13 @@ set(INCLUDE_INSTALL_DIR
add_subdirectory(Eigen)
+add_subdirectory(doc)
+
if(EIGEN_BUILD_TESTS)
include(CTest)
add_subdirectory(test)
endif(EIGEN_BUILD_TESTS)
-add_subdirectory(doc)
-
add_subdirectory(unsupported)
if(EIGEN_BUILD_DEMOS)
@@ -108,3 +108,7 @@ endif(EIGEN_BUILD_DEMOS)
if(EIGEN_BUILD_BTL)
add_subdirectory(bench/btl)
endif(EIGEN_BUILD_BTL)
+
+if(EIGEN_BUILD_TESTS)
+ ei_testing_print_summary()
+endif(EIGEN_BUILD_TESTS) \ No newline at end of file