aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Alexey Frunze <afrunze@wavecomp.com>2018-07-06 16:04:30 -0700
committerGravatar Alexey Frunze <afrunze@wavecomp.com>2018-07-06 16:04:30 -0700
commit3875fb05aaa019c700d68b074e61471a96c85b36 (patch)
treea3ca21891fb7f07bb4b8f521939b4d382e8ae4f8 /CMakeLists.txt
parent44ea5f7623d1d5211de753b4ea719b63d55b228a (diff)
Add support for MIPS SIMD (MSA)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 91545bdb0..0547ee681 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -256,6 +256,12 @@ if(NOT MSVC)
message(STATUS "Enabling VSX in tests/examples")
endif()
+ option(EIGEN_TEST_MSA "Enable/Disable MSA in tests/examples" OFF)
+ if(EIGEN_TEST_MSA)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mmsa")
+ message(STATUS "Enabling MSA in tests/examples")
+ endif()
+
option(EIGEN_TEST_NEON "Enable/Disable Neon in tests/examples" OFF)
if(EIGEN_TEST_NEON)
if(EIGEN_TEST_FMA)