aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Christoph Hertzberg <chtz@informatik.uni-bremen.de>2018-04-21 22:08:26 +0200
committerGravatar Christoph Hertzberg <chtz@informatik.uni-bremen.de>2018-04-21 22:08:26 +0200
commit34e499ad36363692615b800b5dbe6cd496341339 (patch)
tree27cca5571594deb7b2f981d63c833affb699a080 /CMakeLists.txt
parent686fb57233736583c7ff4462aac403591ba762b9 (diff)
Disable -Wshadow when compiling with g++
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8a068739b..5245b2930 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -153,11 +153,7 @@ if(NOT MSVC)
ei_add_cxx_compiler_flag("-Wdouble-promotion")
# ei_add_cxx_compiler_flag("-Wconversion")
- # -Wshadow is insanely too strict with gcc, hopefully it will become usable with gcc 6
- # if(NOT CMAKE_COMPILER_IS_GNUCXX OR (CMAKE_CXX_COMPILER_VERSION VERSION_GREATER "5.0.0"))
- if(NOT CMAKE_COMPILER_IS_GNUCXX)
- ei_add_cxx_compiler_flag("-Wshadow")
- endif()
+ ei_add_cxx_compiler_flag("-Wshadow")
ei_add_cxx_compiler_flag("-Wno-psabi")
ei_add_cxx_compiler_flag("-Wno-variadic-macros")