aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Jean-Christophe Fillion-Robin <jchris.fillionr@kitware.com>2018-09-07 15:50:19 -0400
committerGravatar Jean-Christophe Fillion-Robin <jchris.fillionr@kitware.com>2018-09-07 15:50:19 -0400
commit2cbd9dd49806d686a40841b6d888a83c816efccf (patch)
tree460367c05ef8dfe39dc5d5185641f1ec9cba7866 /CMakeLists.txt
parenta80a290079499a12246939d79e955dbce5f6fc4a (diff)
[PATCH] cmake: Support source include with add_subdirectory and
find_package use This commit allows the sources of the project to be included in a parent project CMakeLists.txt and support use of "find_package(Eigen3 CONFIG REQUIRED)" Here is an example allowing to test the changes. It is not particularly useful in itself. This change will allow to support one of the scenario allowing to create custom 3D Slicer application bundling associated plugins. /tmp/eigen-git-mirror # Eigen sources /tmp/test/CMakeLists.txt: cmake_minimum_required(VERSION 3.12) project(test) add_subdirectory("/tmp/eigen-git-mirror" "eigen-git-mirror") find_package(Eigen3 CONFIG REQUIRED) and configuring it using: mkdir /tmp/test-build && cd $_ cmake \ -DCMAKE_FIND_PACKAGE_NO_PACKAGE_REGISTRY:BOOL=1 \ -DEigen3_DIR:PATH=/tmp/test-build/eigen-git-mirror \ /tmp/test Co-authored-by: Pablo Hernandez <pablo.hernandez@kitware.com> --- CMakeLists.txt | 1 + cmake/Eigen3Config.cmake.in | 4 +++- 2 files changed, 4 insertions(+), 1 deletion(-)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dbf0999ce..6d74709a3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -538,6 +538,7 @@ if (NOT CMAKE_VERSION VERSION_LESS 3.0)
# Imported target support
add_library (eigen INTERFACE)
+ add_library (Eigen3::Eigen ALIAS eigen)
target_compile_definitions (eigen INTERFACE ${EIGEN_DEFINITIONS})
target_include_directories (eigen INTERFACE