aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2011-02-17 16:58:18 +0100
committerGravatar Gael Guennebaud <g.gael@free.fr>2011-02-17 16:58:18 +0100
commit2ba55e90db84d33c83fd9aaaa42004d211779a1d (patch)
tree34ba1234f9681d87f47b7f463a710b728c0cabbb /CMakeLists.txt
parentd0b8ce8f2a7da4fb7610c0a727417dbf307b9afd (diff)
make check no test everything - also rm the EigenTesting cmake sub-project
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 07291fac4..39b29e48d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -277,6 +277,10 @@ add_subdirectory(Eigen)
add_subdirectory(doc EXCLUDE_FROM_ALL)
+add_custom_target(buildtests)
+add_custom_target(check COMMAND "ctest")
+add_dependencies(check buildtests)
+
# CMake/Ctest does not allow us to change the build command,
# so we have to workaround by directly editing the generated DartConfiguration.tcl file
# save CMAKE_MAKE_PROGRAM