aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2013-06-12 13:02:30 +0200
committerGravatar Gael Guennebaud <g.gael@free.fr>2013-06-12 13:02:30 +0200
commit1b92d2ca33a50cc66299c7fcf5067fd7724258ad (patch)
treeb102e2317219b9c6e1e336c33c43402bec240762 /CMakeLists.txt
parentf6c18413168c01fca08ae9e0cfeb650b705858f6 (diff)
Suppress warning #2304: non-explicit constructor with single argument may cause implicit type conversion
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index de25c69f9..5d92da4a6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -150,7 +150,8 @@ if(NOT MSVC)
ei_add_cxx_compiler_flag("-fno-check-new")
ei_add_cxx_compiler_flag("-fno-common")
ei_add_cxx_compiler_flag("-fstrict-aliasing")
- ei_add_cxx_compiler_flag("-wd981") # disbale ICC's "operands are evaluated in unspecified order" remark
+ ei_add_cxx_compiler_flag("-wd981") # disable ICC's "operands are evaluated in unspecified order" remark
+ ei_add_cxx_compiler_flag("-wd2304") # disbale ICC's "warning #2304: non-explicit constructor with single argument may cause implicit type conversion" produced by -Wnon-virtual-dtor
# The -ansi flag must be added last, otherwise it is also used as a linker flag by check_cxx_compiler_flag making it fails
# Moreover we should not set both -strict-ansi and -ansi