aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2011-02-23 09:25:32 +0100
committerGravatar Gael Guennebaud <g.gael@free.fr>2011-02-23 09:25:32 +0100
commit14b164b00e832241856c500f4f9a4e7ef2b6a59d (patch)
tree1787756786d23f912b469ddb243f412365821709 /CMakeLists.txt
parentc78b5fd9aaf8fb3dd01e179c7912834f644fbf11 (diff)
do not try to use Eigen's blas/lapack if they cannot be compiled
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a09a2ea06..f2db30464 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -314,10 +314,6 @@ else()
add_subdirectory(test EXCLUDE_FROM_ALL)
endif()
-add_subdirectory(unsupported)
-
-add_subdirectory(demos EXCLUDE_FROM_ALL)
-
if(NOT MSVC)
if(EIGEN_LEAVE_TEST_IN_ALL_TARGET)
add_subdirectory(blas)
@@ -328,6 +324,10 @@ if(NOT MSVC)
endif()
endif(NOT MSVC)
+add_subdirectory(unsupported)
+
+add_subdirectory(demos EXCLUDE_FROM_ALL)
+
# must be after test and unsupported, for configuring buildtests.in
add_subdirectory(scripts EXCLUDE_FROM_ALL)