aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Konstantinos Margaritis <markos@freevec.org>2017-10-12 15:38:34 -0400
committerGravatar Konstantinos Margaritis <markos@freevec.org>2017-10-12 15:38:34 -0400
commit0e6e027e91c134104d3595e5bfcd4a7d2a44a6dd (patch)
treed6bd1b3eb6f0f00ac46e52e6bb9e2a04a327d4da /CMakeLists.txt
parent6c3475f110a017b3872a94a4ef13d0c8b543faca (diff)
check both z13 and z14 arches
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2e1648fd1..62bf823c8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -271,12 +271,18 @@ if(NOT MSVC)
message(STATUS "Enabling NEON in tests/examples")
endif()
- option(EIGEN_TEST_ZVECTOR "Enable/Disable S390X(zEC13) ZVECTOR in tests/examples" OFF)
- if(EIGEN_TEST_ZVECTOR)
+ option(EIGEN_TEST_Z13 "Enable/Disable S390X(zEC13) ZVECTOR in tests/examples" OFF)
+ if(EIGEN_TEST_Z13)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -march=z13 -mzvector")
message(STATUS "Enabling S390X(zEC13) ZVECTOR in tests/examples")
endif()
+ option(EIGEN_TEST_Z14 "Enable/Disable S390X(zEC14) ZVECTOR in tests/examples" OFF)
+ if(EIGEN_TEST_Z14)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -march=z14 -mzvector")
+ message(STATUS "Enabling S390X(zEC13) ZVECTOR in tests/examples")
+ endif()
+
check_cxx_compiler_flag("-fopenmp" COMPILER_SUPPORT_OPENMP)
if(COMPILER_SUPPORT_OPENMP)
option(EIGEN_TEST_OPENMP "Enable/Disable OpenMP in tests/examples" OFF)