aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benoit Steiner <benoit.steiner.goog@gmail.com>2016-04-29 13:41:26 -0700
committerGravatar Benoit Steiner <benoit.steiner.goog@gmail.com>2016-04-29 13:41:26 -0700
commit07a247dcf4e86f9f741b68e1d8e0897de3eeca57 (patch)
treed103bd20faa1f103035bac2f21507ecc65f97f68 /CMakeLists.txt
parentfa5a8f055aebbf4f39fca26e857351103fab4d11 (diff)
parent0f3c4c8ff4a6635db77195a8919c743f34181cc2 (diff)
Pulled latest updates from upstream
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 003d00c06..5546184a8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -221,10 +221,17 @@ if(NOT MSVC)
message(STATUS "Enabling FMA in tests/examples")
endif()
+<<<<<<< local
option(EIGEN_TEST_AVX512 "Enable/Disable AVX512 in tests/examples" OFF)
if(EIGEN_TEST_AVX512)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mavx512f -mavx512dq")
message(STATUS "Enabling AVX512 in tests/examples")
+=======
+ option(EIGEN_TEST_F16C "Enable/Disable F16C in tests/examples" OFF)
+ if(EIGEN_TEST_F16C)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mf16c")
+ message(STATUS "Enabling F16C in tests/examples")
+>>>>>>> other
endif()
option(EIGEN_TEST_ALTIVEC "Enable/Disable AltiVec in tests/examples" OFF)