aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar a-doumoulakis <anonymous@invalid.net>2017-05-05 19:26:27 +0100
committerGravatar a-doumoulakis <anonymous@invalid.net>2017-05-05 19:26:27 +0100
commit052426b824038bbee1c1c48c3df65dfccd79ae24 (patch)
treee79f12613782bdcc94373cc031959359ebd5522f /CMakeLists.txt
parent0d08165a7f7a95c35dead32ec2d567e9a4b609b0 (diff)
Add support for triSYCL
Eigen is now able to use triSYCL with EIGEN_SYCL_TRISYCL and TRISYCL_INCLUDE_DIR options Fix contraction kernel with correct nd_item dimension
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 13 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fe4227cbb..54f3a7509 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -151,6 +151,10 @@ if(NOT MSVC)
ei_add_cxx_compiler_flag("-Wenum-conversion")
ei_add_cxx_compiler_flag("-Wc++11-extensions")
ei_add_cxx_compiler_flag("-Wdouble-promotion")
+ ei_add_cxx_compiler_flag("-Wno-unused-parameter")
+ ei_add_cxx_compiler_flag("-Wno-ignored-attributes")
+ ei_add_cxx_compiler_flag("-Wno-ignored-qualifiers")
+ ei_add_cxx_compiler_flag("-Wno-sign-compare")
# ei_add_cxx_compiler_flag("-Wconversion")
# -Wshadow is insanely too strict with gcc, hopefully it will become usable with gcc 6
@@ -437,10 +441,17 @@ endif()
# add SYCL
option(EIGEN_TEST_SYCL "Add Sycl support." OFF)
+option(EIGEN_SYCL_TRISYCL "Use the triSYCL Sycl implementation (ComputeCPP by default)." OFF)
if(EIGEN_TEST_SYCL)
set (CMAKE_MODULE_PATH "${CMAKE_ROOT}/Modules" "cmake/Modules/" "${CMAKE_MODULE_PATH}")
- include(FindComputeCpp)
-endif()
+ if(EIGEN_SYCL_TRISYCL)
+ message(STATUS "Using triSYCL")
+ include(FindTriSYCL)
+ else(EIGEN_SYCL_TRISYCL)
+ message(STATUS "Using ComputeCPP SYCL")
+ include(FindComputeCpp)
+ endif(EIGEN_SYCL_TRISYCL)
+endif(EIGEN_TEST_SYCL)
add_subdirectory(unsupported)