aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2009-09-25 13:08:39 +0200
committerGravatar Gael Guennebaud <g.gael@free.fr>2009-09-25 13:08:39 +0200
commit04dc63776a63e5d0ec0237706cb440152d57769e (patch)
tree00f0890a8d4bb6617262adb5cfb90c0307fa9c57 /CMakeLists.txt
parentbdf603caecc72f8250f212c497d6cf2b42e1c054 (diff)
add a wip blas library built on top of Eigen. TODO:
- write extentive unit tests (maybe this already exist in other projects) - the level2 functions still have to be implemented
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 166dbe621..94b2e99d0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -95,7 +95,7 @@ if(MSVC)
option(EIGEN_TEST_SSE2 "Enable/Disable SSE2 in tests/examples" OFF)
if(EIGEN_TEST_SSE2)
if(NOT CMAKE_CL_64)
- # arch is not supported on 64 bit systems, SSE is enabled automatically.
+ # arch is not supported on 64 bit systems, SSE is enabled automatically.
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /arch:SSE2")
endif(NOT CMAKE_CL_64)
message("Enabling SSE2 in tests/examples")
@@ -142,6 +142,10 @@ if(EIGEN_BUILD_DEMOS)
add_subdirectory(demos)
endif(EIGEN_BUILD_DEMOS)
+if(EIGEN_BUILD_BLAS)
+ add_subdirectory(blas)
+endif(EIGEN_BUILD_BLAS)
+
if(EIGEN_BUILD_BTL)
add_subdirectory(bench/btl)
endif(EIGEN_BUILD_BTL)