aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2015-11-30 17:05:42 +0100
committerGravatar Gael Guennebaud <g.gael@free.fr>2015-11-30 17:05:42 +0100
commit034ca5a22dd8f83c7d9b59428c0b8a41b4cfef88 (patch)
tree0fbdb61b27adf57817ffcb81373cbeba005a6d88 /CMakeLists.txt
parentfd727249ada26896881d2f6905883f6ff9bbafe0 (diff)
Clean hardcoded compilation options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 401400a21..aebc6d45d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -118,11 +118,7 @@ endmacro(ei_add_cxx_compiler_flag)
if(NOT MSVC)
# We assume that other compilers are partly compatible with GNUCC
-
-# set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fexceptions")
- set(CMAKE_CXX_FLAGS_DEBUG "-g3")
- set(CMAKE_CXX_FLAGS_RELEASE "-g0 -O2")
-
+
# clang outputs some warnings for unknwon flags that are not caught by check_cxx_compiler_flag
# adding -Werror turns such warnings into errors
check_cxx_compiler_flag("-Werror" COMPILER_SUPPORT_WERROR)