summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 15b6b80..59c94c5 100644
--- a/Makefile
+++ b/Makefile
@@ -1,10 +1,22 @@
CFILES=xcwd.c
CC=gcc
-CFLAGS=-Wall -Werror -Wextra -pedantic -std=gnu99 -O2
+CFLAGS=-Wall -Werror -Wextra -std=gnu99 -O2
LDFLAGS=-lX11
EXE="xcwd"
-O=${CFILES:.c=.o}
prefix=/usr/
+UNAME:=$(shell uname)
+O=${CFILES:.c=.o}
+
+ifeq ($(UNAME), Linux)
+ CFLAGS += -DLINUX
+else
+ ifeq ($(UNAME), FreeBSD)
+ CFLAGS += -I/usr/local/include/ -DFREEBSD
+ LDFLAGS += -L/usr/local/lib -lprocstat
+ else
+ $(error Operating System not supported.)
+ endif
+endif
${EXE}: clean ${O}
${CC} -o $@ ${O} ${CFLAGS} ${LDFLAGS}