summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@debian.org>2018-11-23 11:29:56 -0500
committerGravatar Benjamin Barenblat <bbaren@debian.org>2018-11-23 11:29:56 -0500
commitcbdb9a606052dfec8aed01d95beda0f2aca09a8c (patch)
treeb8134768a5e44e29f6660569709ed23e302647b4 /Makefile
parent0e1f6d65bec111228b67bab7eddbb173aab2a319 (diff)
parente2c777cbf3a226522a4871f97916f0cb0bee3688 (diff)
Merge new upstream snapshot
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile20
1 files changed, 13 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index b25eea8..ac57069 100644
--- a/Makefile
+++ b/Makefile
@@ -2,11 +2,14 @@ CFILES=xcwd.c
CC=gcc
CFLAGS=-Wall -Wextra -std=gnu99 -O2
LDFLAGS=-lX11
-EXE="xcwd"
+EXE=xcwd
prefix=/usr
UNAME:=$(shell uname)
O=${CFILES:.c=.o}
+.PHONY: all clean distclean install
+.SUFFIXES: .c .o
+
ifeq ($(UNAME), Linux)
CFLAGS += -DLINUX
else
@@ -18,12 +21,7 @@ else
endif
endif
-${EXE}: clean ${O}
- ${CC} -o $@ ${O} ${CFLAGS} ${LDFLAGS}
-
-.SUFFIXES: .c .o
-.c.o:
- ${CC} -c $< ${CFLAGS}
+all: ${EXE}
clean:
rm -vf *.o
@@ -34,3 +32,11 @@ distclean: clean
install: ${EXE}
install -m 0755 ${EXE} $(prefix)/bin
+
+${EXE}: ${O}
+ ${CC} -o $@ ${O} ${CFLAGS} ${LDFLAGS}
+
+
+.c.o:
+ ${CC} -c $< ${CFLAGS}
+