summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index a7ae92ed..43395a92 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,6 +11,10 @@ export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
# arm64 and mips64el. See https://bugs.debian.org/871572 for details.
export DEB_CFLAGS_MAINT_APPEND := -fno-code-hoisting
+# Use -D_FORTIFY_SOURCE=1 instead of -D_FORTIFY_SOURCE=2 to prevent performance
+# problems with %n specifiers. See https://bugs.debian.org/934722 for details.
+export DEB_CPPFLAGS_MAINT_APPEND := -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1
+
# Harden SML executables.
export DEB_BUILD_MAINT_OPTIONS := hardening=+all
export MLTONARGS := \