summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGELOG17
-rw-r--r--doc/manual.tex1
2 files changed, 18 insertions, 0 deletions
diff --git a/CHANGELOG b/CHANGELOG
index c36caa3b..db6d0146 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,4 +1,21 @@
========
+20110515
+========
+
+- Cygwin compatibility
+- Compatibility with Gentoo packaging process, including a .ebuild file
+- Change typing of SQL subqueries, to indicate that they may always return NULL
+ (for no rows)
+- Syntactic sugar for GROUP BY with variable numbers of columns
+ (using 'tab.{{c}}', where 'c :: {Type}')
+- 'ALL' for SQL relational operators
+- Add nullable types to the class for valid operands for SQL arithmetic
+- 'alt' attribute for <img>
+- <sup> and <sub> HTML tags
+- Allow 'debug' and 'naughtyDebug' in client-side code, implemented with 'alert'
+- Bug fixes and optimization improvements
+
+========
20110123
========
diff --git a/doc/manual.tex b/doc/manual.tex
index 5deb66fc..daadd37e 100644
--- a/doc/manual.tex
+++ b/doc/manual.tex
@@ -1565,6 +1565,7 @@ $$\begin{array}{l}
\hspace{.1in} \to \mt{selectedFields} ::: \{\{\mt{Type}\}\} \\
\hspace{.1in} \to \mt{selectedExps} ::: \{\mt{Type}\} \\
\hspace{.1in} \to \mt{sql\_relop} \\
+ \hspace{.1in} \to \mt{bool} \; (* \; \mt{ALL} \; *) \\
\hspace{.1in} \to \mt{sql\_query1} \; \mt{free} \; \mt{afree} \; \mt{tables1} \; \mt{selectedFields} \; \mt{selectedExps} \\
\hspace{.1in} \to \mt{sql\_query1} \; \mt{free} \; \mt{afree} \; \mt{tables2} \; \mt{selectedFields} \; \mt{selectedExps} \\
\hspace{.1in} \to \mt{sql\_query1} \; \mt{free} \; \mt{afree} \; \mt{selectedFields} \; \mt{selectedFields} \; \mt{selectedExps}