summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGELOG18
-rwxr-xr-xconfigure22
-rw-r--r--configure.ac4
3 files changed, 31 insertions, 13 deletions
diff --git a/CHANGELOG b/CHANGELOG
index a1a56ebf..4bfd413d 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,4 +1,22 @@
========
+20120110
+========
+
+- Improvements to type inference and error messages
+- New 'dynClass' pseudo-attribute for most HTML tags
+- New 't.*' notation for selecting all columns of a table
+- New SQL functions: 'lower' and 'upper'
+- 'timeFormat' .urp directive
+- Client-side 'debug' and 'naughtyDebug' calls use a browser debug console, if available
+- Allow 'source' values to be returned by RPCs
+- Change the HTML context classification scheme in 'Basis'
+- Rename 'Top.id' to 'ident' to avoid clash with 'Basis.id'
+- More client-side function implementations
+- Some expanded reference manual sections
+- Tweak to linker command line argument order (to prevent issues with new Ubuntu versions)
+- Bug fixes
+
+========
20111127
========
diff --git a/configure b/configure
index 2ea8e51c..6fd4a917 100755
--- a/configure
+++ b/configure
@@ -1,6 +1,6 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.68 for urweb 20111127.
+# Generated by GNU Autoconf 2.68 for urweb 20120110.
#
#
# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1998, 1999, 2000, 2001,
@@ -567,8 +567,8 @@ MAKEFLAGS=
# Identity of this package.
PACKAGE_NAME='urweb'
PACKAGE_TARNAME='urweb'
-PACKAGE_VERSION='20111127'
-PACKAGE_STRING='urweb 20111127'
+PACKAGE_VERSION='20120110'
+PACKAGE_STRING='urweb 20120110'
PACKAGE_BUGREPORT=''
PACKAGE_URL=''
@@ -1305,7 +1305,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures urweb 20111127 to adapt to many kinds of systems.
+\`configure' configures urweb 20120110 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -1375,7 +1375,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of urweb 20111127:";;
+ short | recursive ) echo "Configuration of urweb 20120110:";;
esac
cat <<\_ACEOF
@@ -1478,7 +1478,7 @@ fi
test -n "$ac_init_help" && exit $ac_status
if $ac_init_version; then
cat <<\_ACEOF
-urweb configure 20111127
+urweb configure 20120110
generated by GNU Autoconf 2.68
Copyright (C) 2010 Free Software Foundation, Inc.
@@ -1843,7 +1843,7 @@ cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by urweb $as_me 20111127, which was
+It was created by urweb $as_me 20120110, which was
generated by GNU Autoconf 2.68. Invocation command line was
$ $0 $@
@@ -2191,7 +2191,7 @@ ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $
ac_compiler_gnu=$ac_cv_c_compiler_gnu
-WORKING_VERSION=1
+WORKING_VERSION=0
ac_ext=c
ac_cpp='$CPP $CPPFLAGS'
ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
@@ -3970,7 +3970,7 @@ fi
# Define the identity of the package.
PACKAGE='urweb'
- VERSION='20111127'
+ VERSION='20120110'
# Some tools Automake needs.
@@ -13179,7 +13179,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_write_fail=1
# report actual input values of CONFIG_FILES etc. instead of their
# values after options handling.
ac_log="
-This file was extended by urweb $as_me 20111127, which was
+This file was extended by urweb $as_me 20120110, which was
generated by GNU Autoconf 2.68. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -13245,7 +13245,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
ac_cs_version="\\
-urweb config.status 20111127
+urweb config.status 20120110
configured by $0, generated by GNU Autoconf 2.68,
with options \\"\$ac_cs_config\\"
diff --git a/configure.ac b/configure.ac
index 11ce7ced..51ed488a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
-AC_INIT([urweb], [20111127])
-WORKING_VERSION=1
+AC_INIT([urweb], [20120110])
+WORKING_VERSION=0
AC_USE_SYSTEM_EXTENSIONS
AM_INIT_AUTOMAKE([-Wall -Werror foreign no-define])
AC_PROG_CC()