summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGELOG25
-rwxr-xr-xconfigure22
-rw-r--r--configure.ac4
3 files changed, 38 insertions, 13 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 7407c772..accdd95b 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,4 +1,29 @@
========
+20120512
+========
+
+- New support for CSS style code embedded in Ur/Web programs.
+ Two recommended usage methods:
+ 1. Use 'style' attributes with normal CSS syntax inside string literals.
+ 2. Generate styles programmatically with the Style module of the Gui library
+ (distributed separately).
+- 'dynStyle' attribute, which is to 'style' as 'dynClass' is to 'class'
+- Parsing of standard syntax for 'class' attributes, via specially interpreted
+ string literals
+- New optional suffix for 'rewrite' in .urp files: [-]
+- Compiler error message improvements, including simplification of types
+- New command line parameters: '-boot', '-dumpTypesOnError', '-unifyMore'
+- New .urp directives: 'linker'
+- Support for speeding up compilation by caching type inference results:
+ Run 'urweb daemon start' to spawn a background process,
+ 'urweb daemon stop' to kill it.
+- Enforcement of uniqueness of top-level module names across a project
+- Adjust error message format to match Emacs compilation mode defaults
+- More HTML attributes added
+- New antiquote syntax for 'PRIMARY KEY'
+- Bug fixes and improvements to type inference and platform compatibility
+
+========
20120329
========
diff --git a/configure b/configure
index 8bc630bc..a74fd071 100755
--- a/configure
+++ b/configure
@@ -1,6 +1,6 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.68 for urweb 20120329.
+# Generated by GNU Autoconf 2.68 for urweb 20120512.
#
#
# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1998, 1999, 2000, 2001,
@@ -567,8 +567,8 @@ MAKEFLAGS=
# Identity of this package.
PACKAGE_NAME='urweb'
PACKAGE_TARNAME='urweb'
-PACKAGE_VERSION='20120329'
-PACKAGE_STRING='urweb 20120329'
+PACKAGE_VERSION='20120512'
+PACKAGE_STRING='urweb 20120512'
PACKAGE_BUGREPORT=''
PACKAGE_URL=''
@@ -1307,7 +1307,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures urweb 20120329 to adapt to many kinds of systems.
+\`configure' configures urweb 20120512 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -1377,7 +1377,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of urweb 20120329:";;
+ short | recursive ) echo "Configuration of urweb 20120512:";;
esac
cat <<\_ACEOF
@@ -1480,7 +1480,7 @@ fi
test -n "$ac_init_help" && exit $ac_status
if $ac_init_version; then
cat <<\_ACEOF
-urweb configure 20120329
+urweb configure 20120512
generated by GNU Autoconf 2.68
Copyright (C) 2010 Free Software Foundation, Inc.
@@ -1845,7 +1845,7 @@ cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by urweb $as_me 20120329, which was
+It was created by urweb $as_me 20120512, which was
generated by GNU Autoconf 2.68. Invocation command line was
$ $0 $@
@@ -2193,7 +2193,7 @@ ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $
ac_compiler_gnu=$ac_cv_c_compiler_gnu
-WORKING_VERSION=1
+WORKING_VERSION=0
ac_ext=c
ac_cpp='$CPP $CPPFLAGS'
ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
@@ -3973,7 +3973,7 @@ fi
# Define the identity of the package.
PACKAGE='urweb'
- VERSION='20120329'
+ VERSION='20120512'
# Some tools Automake needs.
@@ -13188,7 +13188,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_write_fail=1
# report actual input values of CONFIG_FILES etc. instead of their
# values after options handling.
ac_log="
-This file was extended by urweb $as_me 20120329, which was
+This file was extended by urweb $as_me 20120512, which was
generated by GNU Autoconf 2.68. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -13254,7 +13254,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
ac_cs_version="\\
-urweb config.status 20120329
+urweb config.status 20120512
configured by $0, generated by GNU Autoconf 2.68,
with options \\"\$ac_cs_config\\"
diff --git a/configure.ac b/configure.ac
index 48bdb813..c8568d2c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
-AC_INIT([urweb], [20120329])
-WORKING_VERSION=1
+AC_INIT([urweb], [20120512])
+WORKING_VERSION=0
AC_USE_SYSTEM_EXTENSIONS
AM_INIT_AUTOMAKE([-Wall -Werror foreign no-define])
AC_PROG_CC()