summaryrefslogtreecommitdiff
path: root/urweb.ebuild
diff options
context:
space:
mode:
authorGravatar Adam Chlipala <adam@chlipala.net>2011-03-26 13:43:47 -0400
committerGravatar Adam Chlipala <adam@chlipala.net>2011-03-26 13:43:47 -0400
commit744aa8a2e9d3812c6600e919efd6a983d1d11335 (patch)
treebbb661b15afebf35e446c00a75562bd46f2a45c1 /urweb.ebuild
parent92f20c72d4e1e2e758182a5577674a903395c733 (diff)
A Gentoo .ebuild file, based mostly on a contribution by moreilcon
Diffstat (limited to 'urweb.ebuild')
-rw-r--r--urweb.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/urweb.ebuild b/urweb.ebuild
new file mode 100644
index 00000000..5b4693d1
--- /dev/null
+++ b/urweb.ebuild
@@ -0,0 +1,42 @@
+# Distributed under the terms of the BSD3 license
+
+# This file needs to be renamed to something like "urweb-20110123.ebuild", to reflect the Ur/Web version to use.
+# It won't work with versions from Ur/Web Mercurial repository snapshots older than this file.
+# (The specific version number referenced above is an example of a version that _won't_ work!
+# There hasn't yet been an official release that will.)
+
+inherit eutils
+
+EAPI=3
+
+DESCRIPTION="A domain-specific functional programming language for modern web applications"
+HOMEPAGE="http://www.impredicative.com/ur/"
+SRC_URI="http://www.impredicative.com/ur/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/mlton
+ dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/urweb"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_configure() {
+ econf || die
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die
+ dodoc CHANGELOG || die
+}