summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorGravatar Adam Chlipala <adam@chlipala.net>2011-08-02 14:45:19 -0400
committerGravatar Adam Chlipala <adam@chlipala.net>2011-08-02 14:45:19 -0400
commit1a96e18000db336129e0a99e3c86e7a57f152402 (patch)
tree2baf2a09402cedd80d6b24f7b001b3c5194cf017 /src
parent18c72ec4eb9f53935a1a1d7145b919f8a8c8684e (diff)
Remove some GCC-specific identifier choice and documentation
Diffstat (limited to 'src')
-rw-r--r--src/c/Makefile.in2
-rw-r--r--src/compiler.sml4
-rw-r--r--src/config.sig2
-rw-r--r--src/config.sml.in2
4 files changed, 5 insertions, 5 deletions
diff --git a/src/c/Makefile.in b/src/c/Makefile.in
index 4b567a16..2c02db8d 100644
--- a/src/c/Makefile.in
+++ b/src/c/Makefile.in
@@ -117,6 +117,7 @@ AUTOMAKE = @AUTOMAKE@
AWK = @AWK@
BIN = @BIN@
CC = @CC@
+CCARGS = @CCARGS@
CCDEPMODE = @CCDEPMODE@
CFLAGS = @CFLAGS@
CPP = @CPP@
@@ -133,7 +134,6 @@ ECHO_T = @ECHO_T@
EGREP = @EGREP@
EXEEXT = @EXEEXT@
FGREP = @FGREP@
-GCCARGS = @GCCARGS@
GREP = @GREP@
INCLUDE = @INCLUDE@
INSTALL = @INSTALL@
diff --git a/src/compiler.sml b/src/compiler.sml
index f12bcbfe..e47e5e2a 100644
--- a/src/compiler.sml
+++ b/src/compiler.sml
@@ -1320,11 +1320,11 @@ fun compileC {cname, oname, ename, libs, profile, debug, link = link'} =
else
"-L" ^ Config.lib ^ "/.. -lurweb " ^ #linkDynamic proto
- val compile = Config.ccompiler ^ " " ^ Config.gccArgs ^ " -Wimplicit -Werror -Wno-unused-value -O3 -I " ^ Config.includ
+ val compile = Config.ccompiler ^ " " ^ Config.ccArgs ^ " -Wimplicit -Werror -Wno-unused-value -O3 -I " ^ Config.includ
^ " " ^ #compile proto
^ " -c " ^ escapeFilename cname ^ " -o " ^ escapeFilename oname
- val link = Config.ccompiler ^ " -Werror -O3 -lm -pthread " ^ Config.gccArgs ^ " " ^ lib ^ " " ^ Config.openssl ^ " " ^ escapeFilename oname
+ val link = Config.ccompiler ^ " -Werror -O3 -lm -pthread " ^ Config.ccArgs ^ " " ^ lib ^ " " ^ Config.openssl ^ " " ^ escapeFilename oname
^ " -o " ^ escapeFilename ename ^ " " ^ libs
val (compile, link) =
diff --git a/src/config.sig b/src/config.sig
index 98455a3c..65c3926b 100644
--- a/src/config.sig
+++ b/src/config.sig
@@ -9,7 +9,7 @@ signature CONFIG = sig
val libJs : string
val ccompiler : string
- val gccArgs : string
+ val ccArgs : string
val openssl : string
val pgheader : string
diff --git a/src/config.sml.in b/src/config.sml.in
index bb5648c9..cd8d941a 100644
--- a/src/config.sml.in
+++ b/src/config.sml.in
@@ -13,7 +13,7 @@ val libJs = OS.Path.joinDirFile {dir = lib,
file = "js"}
val ccompiler = "@CC@"
-val gccArgs = "@GCCARGS@"
+val ccArgs = "@CCARGS@"
val openssl = "@OPENSSL_LDFLAGS@ @OPENSSL_LIBS@"
val pgheader = "@PGHEADER@"