summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@mit.edu>2015-03-10 20:00:21 -0400
committerGravatar Benjamin Barenblat <bbaren@mit.edu>2015-03-10 20:00:21 -0400
commit6b2ed1f1d70bd76a8adb37adacacd99559e1eac9 (patch)
treeade6d3ea723ebc6818425e98408871515a27e11a /debian/rules
parentc895765a02447d3f49ba446f7861dd2e02d23401 (diff)
Harden ML executable
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 6 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 3c670ce5..6374aa4d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,6 +4,12 @@
# Avoid overlinking and reduce library dependencies.
export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+# Harden SML executables.
+export MLTONARGS := \
+ -cc-opt "$(shell dpkg-buildflags --get CPPFLAGS) \
+ $(shell dpkg-buildflags --get CFLAGS)" \
+ -link-opt "$(shell dpkg-buildflags --get LDFLAGS)"
+
%:
dh $@ --parallel --with autoreconf