summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Adam Chlipala <adam@chlipala.net>2015-12-31 17:54:12 -0500
committerGravatar Adam Chlipala <adam@chlipala.net>2015-12-31 17:54:12 -0500
commitf5f93f6efc15ade5945e8572d889f22d198611b9 (patch)
tree3483e6355a6dc48839b55ccb6f742c90233b574e /configure.ac
parentdd92f19fcee5c66e0f63eaf49b746604ddd57210 (diff)
Upgrade M4 macros for pthreads and remove custom workaround
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 0 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index 9f7aebbc..fc7ba433 100644
--- a/configure.ac
+++ b/configure.ac
@@ -94,24 +94,6 @@ if test [$WORKING_VERSION = "1"]; then
VERSION="$VERSION + `git log -1 --format="%H" || echo ?`"
fi
-# Clang does not like being passed -pthread, since it's implicit on OS X.
-# So let's get rid of that! Here's to hoping it doesn't break Clang
-# on other platforms.
-AC_MSG_CHECKING([if compiling with clang])
-AC_COMPILE_IFELSE(
-[AC_LANG_PROGRAM([], [[
-#ifndef __clang__
- not clang
-#endif
-]])],
-[CLANG=yes], [CLANG=no])
-AC_MSG_RESULT([$CLANG])
-
-if test [$CLANG = "yes"]; then
- PTHREAD_CFLAGS=""
- PTHREAD_LIBS=""
-fi
-
# Check if pthread_t is a scalar or pointer type so we can use the correct
# OpenSSL functions on it.
AC_MSG_CHECKING([if pthread_t is a pointer type])